Las copias de seguridad no se pueden editar. Puede reemplazar la versión actual por una copia de seguridad mediante el comando Restore. Para obtener más información, consulte cuadro de diálogo Backup Versions.
Crear copias de seguridad de FlexiLayouts
Las copias de seguridad pueden crearse manual o automáticamente.Creación manual de copias de seguridad
1
Abra el cuadro de diálogo de copia de seguridad
Haga clic en Project → Create backup….
2
Especifique un comentario
Opcionalmente, añada un comentario para la copia de seguridad. Este comentario reemplaza la propiedad Comment del FlexiLayout original.
3
Cree la copia de seguridad
Haga clic en Create.
Crear copias de seguridad automáticamente
FlexiLayout Studio puede crear copias de seguridad automáticamente al exportar un FlexiLayout.1
Abra el cuadro de diálogo Opciones
Haga clic en Herramientas → Opciones y, a continuación, seleccione la pestaña Otros.
2
Elija cuándo crear una versión de copia de seguridad
Seleccione una de las siguientes opciones en la lista desplegable Crear versión de copia de seguridad al exportar.
Cuadro de diálogo Backup Versions
El cuadro de diálogo Backup Versions contiene una lista de copias de seguridad del FlexiLayout actual. Úselo para revertir la versión actual a una copia, eliminar copias o ver las diferencias entre la versión actual y una copia de seguridad. Para abrir el cuadro de diálogo, haga clic en Project → Backup Manager…. En el cuadro de diálogo, puede realizar estas acciones:- Restore – Revertir la versión actual a la copia de seguridad seleccionada.
- Delete – Eliminar la copia de seguridad seleccionada.
- Show changes – Ver las diferencias entre la versión actual y la copia de seguridad seleccionada. Para obtener más información, consulte Visualización de cambios en el árbol de FlexiLayout.
Ver los cambios en el árbol de FlexiLayout
Puede ver las diferencias entre la versión actual del FlexiLayout y una copia de seguridad en forma de lista de elementos y bloques. Cada elemento tiene uno de los siguientes estados.
Si se hicieron cambios en un grupo de elementos, el grupo completo (incluidos los elementos secundarios) aparece en la lista. Los elementos y bloques que no hayan cambiado no se incluyen.
Para ordenar los elementos por nombre o por tipo de cambio, haga clic en el encabezado de columna correspondiente.
Puede abrir elementos directamente desde la lista:
- Para abrir un elemento o bloque en el árbol de FlexiLayout, haga doble clic en él en la lista.
- Para abrir el cuadro de diálogo de propiedades de un elemento o campo en la pestaña que contiene la propiedad modificada, haga doble clic en la propiedad en la lista detallada de cambios.
