Créez et modifiez des dispositions de référence dans ABBYY FlexiLayout Studio afin d’évaluer les résultats de mise en correspondance, de comparer les différences et d’utiliser les outils de modification des blocs.
Vous pouvez créer une disposition de référence pour chaque image du lot. La disposition de référence indique où vous souhaitez que les blocs soient situés sur l’image. Vous pouvez créer une disposition de référence manuellement ou à partir des résultats de la mise en correspondance du FlexiLayout, et vous pouvez la modifier en ajoutant ou en supprimant des blocs et en changeant leur taille et leur position.Les dispositions de référence sont utilisées lors du débogage des FlexiLayouts, car elles vous permettent de comparer les résultats de la mise en correspondance de votre FlexiLayout avec les emplacements des blocs sur chaque image.
Modes Disposition de référence et Disposition des différences
Vous créez des mises en page de référence en mode Disposition de référence. Pour passer à ce mode, cliquez sur dans la barre d’outils.Le mode Disposition des différences (bouton dans la barre d’outils) affiche les différences entre la disposition de référence et les résultats de la mise en correspondance de FlexiLayout.Il met en évidence deux types de zones :
Zones manquantes – Zones présentes dans les blocs de la disposition de référence, mais absentes des blocs détectés par la mise en correspondance de FlexiLayout, surlignées en rouge.
Zones excédentaires – Zones absentes des blocs de la disposition de référence, mais présentes dans les blocs détectés par la mise en correspondance de FlexiLayout, surlignées en vert.
La fenêtre lot affiche les pourcentages de Zones manquantes et de Zones excédentaires.
Sélectionnez Copy Matched Layout to Reference dans le menu lot ou dans le menu contextuel.
4
Ajuster les blocs
Déplacez ou redimensionnez les blocs si la disposition copiée doit être corrigée.
5
Enregistrer la disposition de référence
Cliquez sur dans la barre d’outils.
Vous pouvez également utiliser la commande Copy Matched Layout to Reference dans le menu contextuel du lot pour enregistrer comme disposition de référence les résultats de la mise en correspondance du FlexiLayout avec les pages sélectionnées du lot.
Les commandes de création et de modification des blocs se trouvent dans View → Images → Tool → Select. Les boutons correspondants se trouvent dans la barre d’outils.
Cliquez sur l’outil Select dans la barre d’outils, ou sélectionnez-le dans View → Images → Tool.
2
Placer le pointeur sur le bloc
Placez le pointeur de la souris sur le bloc. Le pointeur change de forme pour indiquer que vous pouvez déplacer le bloc.
3
Faire glisser le bloc
Maintenez le bouton gauche de la souris enfoncé, faites glisser le bloc dans la direction souhaitée, puis relâchez-le.
Il arrive parfois qu’un bloc soit trop petit pour être déplacé, car ses bordures sont très proches les unes des autres et le fait de pointer sur l’une d’elles active le mode de redimensionnement. Maintenez la touche Ctrl enfoncée pour déplacer ces blocs.
Cliquez sur l’outil Create Block dans la barre d’outils, ou sélectionnez-le dans View → Images → Tool.
2
Tracez le bloc
Placez le pointeur de la souris dans un coin du nouveau bloc, maintenez le bouton gauche de la souris enfoncé, faites glisser le pointeur en diagonale dans la direction souhaitée, puis relâchez-le.
3
Nommez le bloc
Dans la boîte de dialogue Create Block, saisissez un nom pour le nouveau bloc.
Sélectionnez Mode d’entraînement dans le menu Entraînement.
2
Sélectionner un bloc ou un élément
Dans la fenêtre FlexiLayout, sélectionnez un bloc ou un élément statique.
3
Sélectionner l’outil Draw Location
Cliquez sur l’outil Draw Location dans la barre d’outils, ou sélectionnez-le dans Affichage → Images → Outil.
4
Dessiner la zone
Placez le pointeur de la souris dans l’angle du nouveau bloc, maintenez enfoncé le bouton gauche de la souris, faites glisser le pointeur en diagonale dans la direction souhaitée, puis relâchez.
Cliquez sur l’outil Cut Region Part dans la barre d’outils, ou sélectionnez-le dans View → Images → Tool.
2
Pointer à l’intérieur du bloc
Placez le pointeur de la souris à l’intérieur du bloc dans lequel vous voulez découper une zone rectangulaire.
3
Faire glisser la zone
Maintenez le bouton gauche de la souris enfoncé, faites glisser le pointeur en diagonale dans la direction souhaitée, puis relâchez-le.
La zone rectangulaire est découpée dans le bloc.
Lorsque vous découpez une zone en haut ou en bas du bloc, la zone adjacente à droite, jusqu’à la bordure du bloc, est également découpée. Cela s’explique par le fait que l’Engine de Reconnaissance optique de caractères (OCR) ne peut reconnaître que des blocs de texte continus. Cette contrainte ne s’applique pas aux zones situées à gauche et à droite.