Skip to main content
Automatisches Lernen ermöglicht es dem System, während der Dokumentverarbeitung aus den Entscheidungen der Operatoren zu lernen und so die Felderkennung zu verbessern. Wenn das System ein Feld nicht finden kann, gibt ein Operator dessen korrekte Position an. Nachdem die korrigierten Dokumente exportiert wurden, verwendet das System diese Korrekturen als Lerngrundlage. Das Training der Feldextraktion kann auch vom Administrator durchgeführt werden, wenn ein Projekt trainiert werden muss, bevor Operatoren daran arbeiten.

Automatisches Lernen konfigurieren

1

Document Definition erstellen

Erstellen Sie eine Document Definition. Wählen Sie in den Abschnittseigenschaften Training von Feldpositionen zulassen aus.
2

Felder erstellen

Erstellen Sie die Felder im Abschnitt und wählen Sie in den Eigenschaften jedes Feldes Can have region aus.
3

Speichern und veröffentlichen

Speichern und veröffentlichen Sie die Document Definition.
4

Trainingsstufe aktivieren

Klicken Sie in den Eigenschaften des Batch-Typs auf Workflow und aktivieren Sie die Stufe Training.
Nachdem der Administrator die Document Definition eingerichtet hat, lernt das System automatisch aus den Korrekturen der Operatoren in den Verifizierungsstationen.

Varianten für automatisches Lernen konfigurieren

Erstellen Sie für Dokumente desselben Typs mit stark unterschiedlichem Erscheinungsbild Varianten für jedes Feldlayout und trainieren Sie einen Klassifikator, damit er sie unterscheiden kann. Weitere Informationen finden Sie unter Variable Feldpositionen in Dokumenten desselben Typs.
1

Abschnittsvarianten hinzufügen

Fügen Sie Abschnittsvarianten mit einer der folgenden Methoden hinzu:
  • Varianten manuell erstellen: Klicken Sie auf der Registerkarte Data Sets der Abschnittseigenschaften auf View und anschließend auf Add.
  • Varianten aus einer Datenbank laden: Klicken Sie auf der Registerkarte Data Sets auf Set Up und wählen Sie Database als Datenquelle aus.
  • Varianten mithilfe eines Skripts erstellen: Klicken Sie auf der Registerkarte Data Sets auf Set Up und wählen Sie Script als Datenquelle aus.
2

Speichern und veröffentlichen

Speichern und veröffentlichen Sie die Document Definition.
3

Klassifikator mit den Varianten trainieren

  1. Wechseln Sie in den Modus Open Classifier Training Batches und laden Sie Dokumentbilder in einen neuen Batch.
  2. Weisen Sie jedem Dokument eine Referenzklasse zu und behandeln Sie Varianten als separate Klassen. Klicken Sie auf Set Class → Add → Add, wählen Sie Specify variant und anschließend eine Variante aus der Liste aus.
  3. Trainieren Sie den Klassifikator über Project → Classification Training → Train.
Damit Operatoren die einem Dokument zugewiesene Variante überprüfen und ändern können, zeigen Sie die Varianten-IDs mit einem Servicefeld im Formular an. Weitere Informationen finden Sie unter Operatoren das Ändern von Varianten ermöglichen.

Funktionsweise des automatischen Lernens

Dokumente, deren Feldpositionen von Operatoren verifiziert und korrigiert wurden, werden einem Trainings-Batch hinzugefügt und mit der aktuellen Version des trainierten FlexiLayouts abgeglichen. Wenn alle Felder korrekt gefunden werden, muss das FlexiLayout nicht erneut trainiert werden. Manchmal findet das FlexiLayout die Felder korrekt, obwohl der Operator sie ändern musste: Die Dokumente wurden mit einer alten oder untrainierten Version verarbeitet, während sie auf die Verifizierung warteten, und das System hat das FlexiLayout in der Zwischenzeit anhand anderer Dokumente trainiert. Diese Dokumente bleiben im Trainings-Batch mit dem Status For testing und werden für Regressionstests verwendet, damit sich zukünftige Versionen nicht verschlechtern. Wenn ein trainiertes FlexiLayout angewendet wird und einige Feldregionen nicht übereinstimmen, werden diese Dokumente zum Trainieren einer neuen Version verwendet und erhalten den Status For training. Das Ergebnis ist eine neue FlexiLayout-Version. FlexiCapture wendet sowohl die neue als auch die vorherige Version auf die Dokumente mit For training und For testing an, prüft, wie gut die erkannten Feldregionen mit den vom Benutzer bestätigten übereinstimmen, behält die Version mit der besten Übereinstimmung bei und löscht die andere.