FlexiLayout-Backups können nicht bearbeitet werden. Sie können die aktuelle Version mithilfe des Befehls Restore durch eine FlexiLayout-Backup ersetzen. Weitere Informationen finden Sie unter Dialogfeld „Backup Versions“.
Erstellen von FlexiLayout-Backups
FlexiLayout-Backups können manuell oder automatisch erstellt werden.Backups von FlexiLayouts manuell erstellen
1
Das Backup-Dialogfeld öffnen
Klicken Sie im Menü Project auf Create backup….
2
Einen Kommentar angeben
In dem Dialogfeld, das daraufhin geöffnet wird, können Sie einen Kommentar für die FlexiLayout-Backup angeben. Dieser Kommentar ersetzt den Parameter Comment des ursprünglichen FlexiLayouts.
3
Die FlexiLayout-Backup erstellen
Klicken Sie auf die Schaltfläche Create, um die FlexiLayout-Backup zu erstellen.
Backup-Kopien automatisch erstellen
FlexiLayout Studio kann beim Exportieren eines FlexiLayouts automatisch FlexiLayout-Backups erstellen.1
Öffnen Sie das Dialogfeld Options
Klicken Sie auf Tools → Options und wählen Sie dann die Registerkarte Other aus.
2
Legen Sie fest, wann eine Backup-Version erstellt werden soll
Wählen Sie in der Dropdown-Liste Create backup version on export eine der folgenden Optionen aus.
Dialogfeld „Backup Versions“
Das Dialogfeld Backup Versions führt die FlexiLayout-Backups des aktuellen FlexiLayouts auf. Verwenden Sie es, um die aktuelle Version auf eine FlexiLayout-Backup zurückzusetzen, Kopien zu löschen oder die Unterschiede zwischen der aktuellen Version und einer FlexiLayout-Backup anzuzeigen. Um das Dialogfeld zu öffnen, klicken Sie auf Project → Backup Manager…. Im Dialogfeld können Sie die folgenden Aktionen ausführen:- Restore – Setzt die aktuelle Version auf die ausgewählte FlexiLayout-Backup zurück.
- Delete – Löscht die ausgewählte FlexiLayout-Backup.
- Show changes – Zeigt die Unterschiede zwischen der aktuellen Version und der ausgewählten FlexiLayout-Backup an. Weitere Informationen finden Sie unter Anzeigen von Änderungen am FlexiLayout-Baum.
Änderungen im FlexiLayout-Baum anzeigen
Sie können die Unterschiede zwischen der aktuellen Version des FlexiLayouts und einer FlexiLayout-Backup als Liste von Elementen und Blöcken anzeigen. Jeder Eintrag hat einen der folgenden Status.
Wenn Änderungen an einer Gruppe von Elementen vorgenommen wurden, wird die gesamte Gruppe (einschließlich untergeordneter Elemente) in der Liste angezeigt. Elemente und Blöcke, die nicht geändert wurden, sind nicht in der Liste enthalten.
Um Einträge nach Namen oder nach der Art der Änderungen zu sortieren, klicken Sie auf die entsprechende Spaltenüberschrift.
Sie können Einträge direkt aus der Liste öffnen:
- Um ein Element oder einen Block im FlexiLayout-Baum zu öffnen, doppelklicken Sie in der Liste darauf.
- Um das Dialogfeld „Eigenschaften“ eines Elements oder Felds auf der Registerkarte zu öffnen, die die geänderte Eigenschaft enthält, doppelklicken Sie in der detaillierten Änderungsliste auf die Eigenschaft.
