Erstellen und bearbeiten Sie Referenzlayouts in ABBYY FlexiLayout Studio, um Matching-Ergebnisse als Referenz zu verwenden, Unterschiede zu vergleichen und mit Werkzeugen zum Zeichnen von Blöcken zu arbeiten.
Sie können für jedes Bild im Batch ein Referenzlayout erstellen. Das Referenzlayout zeigt, wo sich die Blöcke auf dem Bild befinden sollen. Sie können ein Referenzlayout manuell oder anhand der Matching-Ergebnisse des FlexiLayouts erstellen, und Sie können es bearbeiten, indem Sie Blöcke hinzufügen oder entfernen sowie ihre Größe und Position ändern.Referenzlayouts werden beim Debuggen von FlexiLayouts verwendet, da Sie damit die Matching-Ergebnisse Ihres FlexiLayouts mit den Blockpositionen auf jedem Bild vergleichen können.
Sie erstellen Referenzlayouts im Modus Referenzlayout. Um zu diesem Modus zu wechseln, klicken Sie in der Symbolleiste auf .Im Modus Difference layout (Schaltfläche in der Symbolleiste) wird der Unterschied zwischen dem Referenzlayout und den Ergebnissen des Abgleichs des FlexiLayouts angezeigt.Dabei werden zwei Arten von Bereichen hervorgehoben:
Missing Areas – Bereiche, die in den Blöcken des Referenzlayouts vorhanden sind, aber in den durch den Abgleich des FlexiLayouts erkannten Blöcken fehlen, werden rot hervorgehoben.
Excess Areas – Bereiche, die in den Blöcken des Referenzlayouts fehlen, aber in den durch den Abgleich des FlexiLayouts erkannten Blöcken vorhanden sind, werden grün hervorgehoben.
Im Fenster Batch werden die Prozentsätze von Missing Areas und Excess Areas angezeigt.
Wählen Sie Copy Matched Layout to Reference im Menü Batch oder im Kontextmenü aus.
4
Die Blöcke anpassen
Verschieben Sie die Blöcke oder ändern Sie ihre Größe, wenn das kopierte Layout korrigiert werden muss.
5
Das Referenzlayout speichern
Klicken Sie auf in der Symbolleiste.
Sie können auch den Befehl Copy Matched Layout to Reference im Kontextmenü des Batches verwenden, um die Ergebnisse des Abgleichs des FlexiLayouts mit ausgewählten Batch-Seiten als Referenzlayout zu speichern.
Die Befehle zum Erstellen und Bearbeiten von Blöcken finden Sie unter View → Images → Tool → Select. Die entsprechenden Schaltflächen dazu befinden sich auf der Symbolleiste.
Klicken Sie in der Symbolleiste auf das Werkzeug Select oder wählen Sie es unter View → Images → Tool aus.
2
Auf den Rand zeigen
Positionieren Sie den Mauszeiger auf dem Blockrand, den Sie verschieben möchten.
3
Den Rand ziehen
Halten Sie die linke Maustaste gedrückt, ziehen Sie den Rand in die gewünschte Richtung und lassen Sie die Maustaste los.
Wenn Sie den Mauszeiger auf eine Ecke des Blocks setzen, werden beim Ziehen mit der Maus sowohl der vertikale als auch der horizontale Blockrand verschoben.
Klicken Sie in der Symbolleiste auf das Werkzeug Select oder wählen Sie es unter Ansicht → Bilder → Werkzeug aus.
2
Auf den Block zeigen
Bewegen Sie den Mauszeiger auf den Block. Die Zeigerform ändert sich und zeigt an, dass Sie den Block verschieben können.
3
Den Block ziehen
Halten Sie die linke Maustaste gedrückt, ziehen Sie den Block in die gewünschte Richtung und lassen Sie die Maustaste los.
Manchmal ist ein Block zu klein, um ihn zu verschieben, weil seine Ränder sehr dicht beieinander liegen und beim Zeigen auf einen davon der Modus zum Ändern der Größe aktiviert wird. Halten Sie die Strg-Taste gedrückt, um solche Blöcke zu verschieben.
Klicken Sie in der Symbolleiste auf das Werkzeug Create Block oder wählen Sie es unter View → Images → Tool aus.
2
Den Block zeichnen
Setzen Sie den Mauszeiger in die Ecke des neuen Blocks, halten Sie die linke Maustaste gedrückt, ziehen Sie die Ecke diagonal in die gewünschte Richtung und lassen Sie dann los.
3
Den Block benennen
Geben Sie im Dialogfeld Create Block einen Namen für den neuen Block ein.
Wählen Sie im Menü Training den Trainingsmodus aus.
2
Einen Block oder ein Element auswählen
Wählen Sie im Fenster FlexiLayout einen Block oder ein statisches Element aus.
3
Das Werkzeug „Position zeichnen“ auswählen
Klicken Sie in der Symbolleiste auf das Werkzeug Position zeichnen oder wählen Sie es unter Ansicht → Bilder → Werkzeug aus.
4
Die Position zeichnen
Platzieren Sie den Mauszeiger in einer Ecke des neuen Blocks, halten Sie die linke Maustaste gedrückt, ziehen Sie die Ecke diagonal in die gewünschte Richtung und lassen Sie die Maustaste los.
Einen rechteckigen Bereich aus einem Block ausschneiden
1
Das Werkzeug „Cut Region Part“ auswählen
Klicken Sie in der Symbolleiste auf das Werkzeug Cut Region Part oder wählen Sie es unter Ansicht → Bilder → Werkzeug aus.
2
In den Block zeigen
Platzieren Sie den Mauszeiger innerhalb des Blocks, aus dem Sie einen rechteckigen Bereich ausschneiden möchten.
3
Den Bereich ziehen
Halten Sie die linke Maustaste gedrückt, ziehen Sie den Zeiger diagonal in die gewünschte Richtung und lassen Sie die Maustaste los.
Das Rechteck wird aus dem Block ausgeschnitten.
Wenn Sie obere oder untere Bereiche eines Blocks ausschneiden, wird auch der angrenzende Bereich rechts davon bis zur Blockgrenze ausgeschnitten. Das geschieht, weil die OCR-Engine nur zusammenhängende Textblöcke erkennen kann. Diese Einschränkung gilt nicht für linke und rechte Bereiche.