テスト バッチを操作できるのは、そのテスト バッチを作成したユーザーだけです。必要に応じて、作業バッチをテスト バッチとして使用することもできます。この場合、作業バッチはテスト バッチの画像ソースとして使用されます。
Document Definition エディターでのテスト
Document Definition は、作成に使用した画像上で、Document Definition エディターから直接テストできます。テストを開始するには、Testing → Run Test を選択します。文書処理時と同様にデータ フォームが表示され、フォーマット エラー、不確かな文字、ルール エラーが示されます。 Testing → View メニューを使用してウィンドウを再配置し、Testing → Verification メニューを使用して検証アイテム、不確かな文字、ルール エラー間を移動します。テストを終了するには、Close をクリックするか、Testing → Finish Test を選択します。テスト モードでは、文書ウィンドウで field の境界線を変更した場合とは異なり、field の境界線を変更しても再認識は行われません。
テスト バッチでのテスト
他の画像で Document Definition をテストするには、Document Definition エディターでテスト バッチを選択します (Batch → Switch to Test Batch)。バッチ選択ダイアログが表示される前に、ABBYY FlexiCapture は現在の Document Definition にエラーがないか確認します。Document Definition にエラーがなければ保存され、バッチ選択ダイアログが表示されます。バッチを選択すると、メイン ウィンドウがアクティブになり、そのバッチに切り替わります。テスト バッチでは、既定で Enable auto export オプションがオフになっています。これにより、テスト結果が作業プロジェクトのフォルダーに誤って保存されるのを防ぎます。
バッチ間で文書をコピーまたは移動する
たとえば、デバッグのために作業バッチからテスト バッチへ文書をコピーまたは移動できます。照合された Document Definition や認識データなど、文書に関するすべての情報が保持されます。 文書をコピーまたは移動するには、バッチの内容一覧で文書を選択します。コピーするには Ctrl+C、移動するには Ctrl+X を押します (または、ツールバーの Copy ボタンまたは Cut ボタン、あるいは Edit メニューの Copy コマンドまたは Cut コマンドを使用します)。次に、移動先のバッチを開き、Ctrl+V を押します (または、ツールバーの Paste ボタン、または Edit → Paste を使用します)。テストで検証される内容
テストでは、文書を処理する際に実行する一連の操作をすべて行います。これにより、次の点を検証できます。- Document Definition を確実に適用できるよう、十分な数のアンカーと識別子がマークされていること。
- field propertiesが正しく設定されていること。
- rulesが正しく設定されていること。
- Exportが正しく設定されていること。
