Skip to main content
Für Dokumente wie Abrechnungen, Zahlungsanweisungen oder Rechnungen können Sie keine gewöhnliche Dokumentdefinition mit festen Feldpositionen verwenden. Position, Größe und Anzahl der Felder können von Dokument zu Dokument variieren, sodass eine feste Dokumentdefinition nicht einheitlich auf alle angewendet werden kann. Für diese Dokumente muss eine Dokumentdefinition eine spezielle logische Beschreibung namens FlexiLayout enthalten, die ABBYY FlexiCapture hilft, die erforderlichen Felder anhand von Schlüsselwörtern und der relativen Position der Felder zueinander zu finden. Erstellen Sie FlexiLayouts in ABBYY FlexiLayout Studio, das zusammen mit ABBYY FlexiCapture geliefert wird. Weitere Informationen finden Sie in der Dokumentation zu ABBYY FlexiLayout Studio. Nachdem Sie ein FlexiLayout erstellt haben, exportieren Sie es in eine *.afl-Datei und hängen es anschließend an Ihre Dokumentdefinition in ABBYY FlexiCapture an. Ein FlexiLayout kann für die gesamte Dokumentdefinition oder für einen ihrer Abschnitte gelten und mehrere Seiten umfassen.
Zusätzlich zu einem Haupt-FlexiLayout können Sie für ein Dokument beliebig viele zusätzliche FlexiLayouts erstellen. FlexiCapture wendet zuerst das Haupt-FlexiLayout und danach nacheinander jedes der zusätzlichen FlexiLayouts an. Wenn die Namen und Typen der Felder im Haupt-FlexiLayout und in den zusätzlichen FlexiLayouts identisch sind, werden die Felder zusammengeführt. Wenn die Namen identisch sind, die Typen jedoch unterschiedlich sind, können die zusätzlichen FlexiLayouts nicht geladen werden, und es wird eine Fehlermeldung angezeigt.

FlexiLayout anhängen

Sie können beim Erstellen einer Dokumentdefinition ein FlexiLayout anhängen. Fügen Sie im zweiten Schritt des Assistenten für Dokumentdefinitionen das Dokumentbild hinzu, wählen Sie die Option FlexiLayout laden und geben Sie den Pfad zur *.afl-Datei ein, die das FlexiLayout enthält. Sie können ein FlexiLayout auch im Dokumentdefinitionseditor über das Dialogfeld „Eigenschaften“ des Dokumentdefinitionsabschnitts anhängen.
1

Abschnitteigenschaften öffnen

Wählen Sie einen Dokumentabschnitt aus. Wenn das Dokument nur aus einem Abschnitt besteht, klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Pages und wählen Sie den Namen des Abschnitts aus. Klicken Sie mit der rechten Maustaste und wählen Sie im Kontextmenü Properties.
2

Registerkarte „FlexiLayout“ öffnen

Klicken Sie auf die Registerkarte FlexiLayout.
3

FlexiLayout-Datei laden

Klicken Sie auf Load und wählen Sie dann die gewünschte *.afl-Datei aus, die das FlexiLayout enthält.
Nachdem Sie ein FlexiLayout angehängt haben, wird das Layout der Felder auf dem Bild angezeigt. Konfigurieren Sie die Feldeigenschaften wie für eine feste Dokumentdefinition. Legen Sie die Eigenschaften für Erkennung, Verifizierung und Export fest und definieren Sie die erforderlichen Regeln.

Ein FlexiLayout aktualisieren

1

Dialogfeld „FlexiLayouts aktualisieren“ öffnen

Klicken Sie auf Tools → FlexiLayouts aktualisieren.
2

FlexiLayouts aktualisieren

Geben Sie im Dialogfeld die Pfade zu den FlexiLayouts an und klicken Sie auf Aktualisieren.
Wenn Sie ein FlexiLayout mit Textdateien importieren, die mögliche Feldwerte enthalten, verwendet FlexiCapture die beim Erstellen des FlexiLayouts definierten relativen Pfade. Diese Pfade beziehen sich auf die Projektdatei. Um die Dateien zu bearbeiten, speichern Sie das Projekt lokal (klicken Sie auf Project → Projekt exportieren), bearbeiten Sie die Dateien und aktualisieren Sie anschließend das Projekt auf dem Server (klicken Sie auf Project → Projekt aktualisieren).