Skip to main content
Una vez reconocidos los datos, el usuario los ve en la ventana Document. De forma predeterminada, los datos se muestran secuencialmente, con etiquetas que coinciden con los nombres de los campos de la Definición de Document. El administrador de la estación puede cambiar cómo se muestran los datos, reorganizándolos o cambiando el nombre de los elementos, modificando el formulario de datos en el editor de Definición de Document.

Personalizar la visualización de los datos

1

Abra el editor de Definición de Document

Abra la Definición de Document en el editor de Definición de Document.
2

Muestre el formulario de datos

Haga clic en Ver → Formulario de datos o pulse Alt+F2.
3

Personalice el formulario de datos

Use los comandos del menú contextual para personalizar el formulario de datos.
Para obtener más información, consulte Configuración del formulario de datos. Para restaurar la configuración predeterminada de la vista del formulario de datos, haga clic en Restaurar vista predeterminada en el menú contextual. Se perderán todos los cambios realizados por el usuario.

Propiedades de los elementos del formulario de datos

Cada tipo de elemento del formulario de datos tiene su propio conjunto de propiedades. Para ver las propiedades de un elemento, haga doble clic en él o haga clic con el botón derecho y, en el menú contextual, haga clic en Propiedades.

Pestaña Posición

  • Alineación – Ajusta la alineación de un elemento en los ejes vertical y horizontal. También puede usar los menús contextuales de los elementos para cambiar su alineación.
  • Márgenes – Cambia la distancia, en puntos, entre un elemento y los bordes de su celda. Si especifica un margen de cero, FlexiCapture usa el margen más pequeño que impida que los elementos se superpongan. También puede cambiar los márgenes mediante los comandos del menú contextual del elemento, arrastrándolo dentro de su celda o moviendo los bordes derecho o inferior de la celda hasta que toquen el elemento.
  • Establecer tamaño mínimo – Especifica el ancho y el alto mínimos de un elemento. Si no se especifica un tamaño mínimo, se determina automáticamente. También puede cambiar el ancho y el alto mínimos arrastrando los bordes del elemento. Para restaurar el tamaño predeterminado del elemento, haga clic con el botón derecho en él y seleccione Restaurar tamaño predeterminado en el menú contextual. Los elementos cuyo tamaño mínimo se calcula automáticamente se resaltan en verde en el formulario de datos; los elementos cuyo tamaño mínimo especifica el usuario se resaltan en rojo.
  • Ancho fijo – Indica que el elemento tiene un ancho fijo. Esta configuración solo funciona si el campo es lo suficientemente grande como para contener al menos un carácter. Si se introduce una cadena de texto muy larga en un campo cuyo ancho no es fijo, el campo se expande para ajustarse al texto. Cuando especifica un ancho fijo, las cadenas de texto largas se ajustan al tamaño del campo.

Pestaña Formato (cuadro de etiqueta)

  • Text – El texto de la etiqueta (normalmente, el nombre de un campo o una explicación).
  • Font – Cambia la fuente, el tamaño y el estilo de la fuente. La fuente y el tamaño de fuente especificados en la Definición de Document se usan de forma predeterminada. Para cambiar esta configuración, desactive la opción Use default.
Puede cambiar la etiqueta de un campo en el formulario de datos sin cambiar el nombre del campo en la estructura del documento. Esto resulta útil cuando no puede cambiar los nombres de los campos o cuando necesita nombres personalizados para las columnas de las tablas. También puede agregar texto, como explicaciones para los campos, haciendo clic con el botón derecho en un espacio vacío del formulario de datos y haciendo clic en Insert Text en el menú contextual.

Pestañas Formato e Instancias (propiedades de grupo)

  • Configuración de visualización para grupos de campos – Cambie la apariencia predeterminada de los grupos de campos en la ventana Document. Haga clic con el botón derecho en un grupo del formulario de datos, abra el cuadro de diálogo de propiedades, seleccione la pestaña Formato y elija una de las siguientes opciones en la lista desplegable Contraer grupo:
  • Mostrar borde – Muestra u oculta el borde alrededor del grupo en la ventana Document. Si un grupo contiene instancias y su borde está oculto, aparecen controles rectangulares a la izquierda de las instancias. Use estos controles para eliminar una instancia y agregar una nueva una posición por encima o por debajo de la instancia seleccionada.
  • Mostrar el mensaje “Agregar nueva instancia” – Muestra u oculta un enlace que invita al usuario a agregar una instancia en grupos o campos con instancias.
Las propiedades de los elementos descritas aquí, la resolución de pantalla, el nivel de zoom del formulario y el contenido de las celdas se utilizan para calcular la posición de los campos en el formulario de datos.

Configuración del formulario de datos

Fuente y tamaño de fuente

De forma predeterminada, el texto reconocido utiliza Arial de 10 pt. Cambie la configuración predeterminada en el cuadro de diálogo Propiedades de Definición de Document (haga clic en Document Definition → Document Definition Properties y seleccione la pestaña formulario de datos).
  • Field data – Configuración de fuente del texto reconocido.
  • Field label – Configuración de fuente del texto explicativo y las etiquetas de campo.

Visualización de imágenes de campos en la ventana Document

Puede mostrar una imagen de los campos Text, Barcode, Checkmark y Group of checkmarks debajo de los datos reconocidos en la ventana Document.
Captura de pantalla del formulario de datos de la ventana Document que muestra un campo de dirección reconocido con una imagen del campo mostrada debajo de los datos reconocidos.
Para mostrar una imagen de un campo, haga clic con el botón derecho en el campo del formulario de datos y seleccione Add Field Picture en el menú contextual. Cuando finalice el procesamiento, los datos extraídos aparecerán en la ventana Document con una imagen del campo debajo.

Elementos de grupo

Puede combinar varios elementos en un grupo y colocarlos en el formulario de datos. Use los comandos del menú contextual para alinear el grupo y establecer los márgenes (eliminar o restablecer los valores predeterminados). También puede eliminar o bloquear el grupo; los elementos de un grupo bloqueado no se pueden mover. Para agrupar elementos, selecciónelos haciendo clic mientras mantiene presionada la tecla Ctrl, haga clic con el botón derecho en uno de ellos y seleccione Group Selected en el menú contextual. Para quitar elementos de un grupo, arrástrelos fuera de él.
Cuando se añade una etiqueta o una imagen a un campo, estos elementos se agrupan.

Configuración de visualización de columnas

Las columnas de tabla que no se detectaron durante el reconocimiento se pueden ocultar. Puede ocultar columnas en dos lugares:
  • En el formulario de datos – Abra las propiedades de la tabla y seleccione las columnas que se deben ocultar en la lista Select columns to hide when empty de la pestaña Formato.
  • En la ventana Document – Haga clic con el botón derecho en el título de la tabla y seleccione en el menú contextual los nombres de las columnas que se deben ocultar.
Use los botones Move Up y Move Down a la derecha de la lista para cambiar el orden de las columnas en el documento reconocido. Esta función no está disponible en las estaciones web.

Configuración de visualización de secciones

Al trabajar con conjuntos de documentos o con Definiciones de Document de varias secciones, puede que desee ocultar secciones concretas en el formulario de datos. Abra el cuadro de diálogo de propiedades de la sección que desea ocultar y desactive la opción Show on verification en la pestaña General.

Orden de selección de los campos

El orden de verificación predeterminado en la ventana Document es de arriba abajo y de izquierda a derecha. Puede cambiar el orden de selección de los campos cuando el usuario pulsa Tab, F4 o F8. Para cambiar el orden, haga clic en Orden de tabulación en el menú contextual del formulario de datos. En el cuadro de diálogo que se abre, seleccione la opción Personalizado y use los botones de la derecha para modificar el orden.
Esta función no está disponible en las estaciones web.

Ampliar la imagen del documento

Durante la verificación, puede ampliar la imagen del documento con el mouse o mediante los comandos del menú contextual. Al hacer doble clic en distintas partes de la imagen del documento, cambia el nivel de zoom: Puede cambiar la disposición de las páginas de horizontal a vertical haciendo clic con el botón derecho en el título de la ventana Document y seleccionando Organizar páginas verticalmente en el menú contextual.
También puede ampliar y reducir usando la rueda del mouse mientras mantiene presionada la tecla Ctrl.