Skip to main content
Pour chaque classificateur, créez un lot d’entraînement, ajoutez des images d’entraînement et attribuez des classes de référence.

Créer un lot d’entraînement

1

Ouvrir la vue des lots d’entraînement du classificateur

Effectuez l’une des opérations suivantes :
  • Cliquez sur le bouton Open Classifier Training Batches dans la barre d’outils.
  • Sélectionnez Open Classifier Training Batches dans le menu View ou Entraînement à la classification.
  • Appuyez sur Ctrl+Alt+Maj+B.
2

Créer un lot

Cliquez avec le bouton droit dans la liste des lots, puis cliquez sur New Batch dans le menu contextuel.
3

Définir le profil de classification

Sélectionnez Change Classification Profile dans le menu Entraînement à la classification ou dans le menu contextuel du lot. Pour plus d’informations, consultez Profils de classification.
4

Définir l’équilibre précision/rappel

Sélectionnez Change Recall/Precision Priority dans le menu Entraînement à la classification ou dans le menu contextuel du lot. Pour plus d’informations, consultez Équilibre précision/rappel.
5

Ajouter des images d’entraînement

Effectuez l’une des opérations suivantes :
  • Cliquez sur Load Images from Folders dans la barre d’outils ou sélectionnez cette option dans le menu File, puis choisissez le dossier contenant les sous-dossiers d’images. Chaque sous-dossier ne doit contenir que des images d’une seule classe.
  • Cliquez sur Load Images dans le menu contextuel du lot ou dans le menu File.
6

Attribuer une classe de référence

Utilisez l’une des méthodes suivantes :
  • Cliquez sur Set Class dans le menu Entraînement à la classification ou cliquez avec le bouton droit sur un document, puis sur Set Class. Sélectionnez une classe de référence ou créez-en une, puis associez-la à une section ou à une variante de section. Vous pouvez utiliser des sections ou des variantes de section comme classes de référence. La classe de référence doit avoir le même nom que la Document Definition correspondante.
  • Si vous avez ajouté les images avec Load Images from Folders, attribuez les classes en fonction du nom des sous-dossiers : sélectionnez les images et cliquez sur le bouton Set Class Based on Subfolder Name dans la barre d’outils, ou sélectionnez Entraînement à la classification → Set Class Based on Subfolder Name.
Le prétraitement de l’image s’applique uniquement aux pages ajoutées avec Load Images. Les pages ajoutées avec Load Images from Folders sont traitées conformément aux Propriétés du projet. Pour les profils Image et Combined, utilisez des images d’entraînement ayant le même schéma de couleurs (par exemple, noir et blanc) que les images à classer.
Si le nom d’une classe correspond au nom d’une section de définition de document, ils sont automatiquement associés lorsque vous cliquez sur Autocorrect dans la boîte de dialogue Mise en correspondance des classes. Pour plus d’informations, consultez Mettre en correspondance les classes avec les sections de définition de document.

Attribuer des classes de référence à partir des résultats de classification

Si vous disposez de nombreuses images non triées pour l’entraînement, entraînez le classificateur sur certaines d’entre elles, puis attribuez des classes de référence aux autres en fonction des résultats.
1

Définir manuellement certaines classes de référence

Attribuez des classes de référence à certaines images à l’aide de Set Class.
2

Entraîner le classificateur

Cliquez sur le bouton Train dans la barre d’outils ou sélectionnez Train dans le menu Entraînement à la classification ou le menu contextuel.
3

Classer les images restantes

Sélectionnez les images qui n’ont pas de classe de référence et cliquez sur le bouton Classify dans la barre d’outils ou sélectionnez Classify dans le menu Entraînement à la classification ou le menu contextuel. Une classe de résultat est attribuée à chaque image en fonction du classificateur entraîné.
4

Promouvoir les classes de résultat en classes de référence

Une fois les images sélectionnées, cliquez sur Set Class Based on Classification Result dans le menu Entraînement à la classification ou le menu contextuel. La classe de résultat de chaque image devient sa classe de référence. Corrigez les images auxquelles une classe de résultat incorrecte a été attribuée.
Pour réutiliser les résultats de reconnaissance existants lors de la mise en correspondance des Document Definition, sélectionnez Prefer settings from batch type dans l’onglet Classification des propriétés du lot d’entraînement (menu contextuel du lot → Properties). Les paramètres de reconnaissance de tout le texte sont ainsi synchronisés, ce qui évite de reconnaître à nouveau les documents et réduit le temps de classification.