このセクションを利用できるのは、システム管理者の権限を持つユーザーのみです。
以前のバージョンの ABBYY FlexiCapture で作成したデータベースに接続する
ABBYY FlexiCapture 12 をインストールした後、以前のバージョンで作成したデータベースとファイルストレージに接続できます。接続するとデータベースは FlexiCapture 12 形式に更新され、その後は以前のバージョンでは使用できなくなります。データベースは以前のバージョンで使用できなくなるため、事前にバックアップコピーを作成することを検討してください。Microsoft SQL Server、Azure、Oracle、または PostgreSQL でバックアップを作成し、ファイルストレージの内容をすべてコピーしてください。バックアップ手順については、ご使用のデータベース管理システムのドキュメントを参照してください。
1
以前のバージョンでの処理を完了する
既存のすべてのバッチの処理を完了します。必要に応じて、管理および監視コンソールを開き、Settings → Cleanup をクリックして不要なデータを削除します。
2
すべてのセッションを閉じる
管理および監視コンソールで、System Monitor → Sessions をクリックし、アクティブなセッションがあるすべてのクライアントを閉じます。
アクティブなセッションがあるすべてのクライアントを閉じられない場合は、Application Server をデータベースから切断してください。レジストリエディターを開き、
HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\10.0 (or 11.0)\WebServices DBConnectionString の値を削除します。次に、Windows Services Console (services.msc) で World Wide Web Publishing Service を再起動します。これにより、以前のバージョンの ABBYY FlexiCapture は使用できなくなります。3
以前のバージョンのデータベースに接続する
ABBYY FlexiCapture 12 の管理および監視コンソールで、Settings → Application server をクリックし、次に Connect to Existing Database をクリックします。以前のバージョンで使用していたデータベースサーバー名、データベース名、およびファイルストレージへのパスを指定します。OK をクリックします。詳細については、既存のデータベースに接続するを参照してください。
4
データベースを更新する
Settings → Application server をクリックし、次にデータベース名の横にある Update リンクをクリックします。
データベースを更新すると、以前のバージョンの FlexiCapture とは互換性がなくなります。
5
各Projectを開いて更新する
ABBYY FlexiCapture 12 の Project Setup Station で、Application Server 上の各 Project を開きます。Project を開くと、ABBYY FlexiCapture 12 形式に更新されます。
更新されたProjectは、以前のバージョンのプログラムと互換性がなくなります。
6
Document Definitions を公開する
更新されたProject内の Document Definitions は Edited ステータスになるため、使用する前に公開する必要があります。Project Setup Station で、Project メニューの Document Definitions をクリックし、Document Definitions を選択してから Publish をクリックします。
以前のバージョンの ABBYY FlexiCapture からProjectをインポートする
以前のバージョンを引き続き使用しながら、そのProjectを ABBYY FlexiCapture 12 でも使用するには、新しい FlexiCapture 12 データベースを作成し、そこにProjectをインポートします。1
Projectをファイルにエクスポートする
以前のバージョンの Project Setup Station で各Projectを開き、Project メニューの Export Project… をクリックしてエクスポートします。
まだ処理中のドキュメントがある場合は、エクスポートする前に処理を完了してください。ドキュメントはProjectと一緒にはエクスポートされません。
2
ABBYY FlexiCapture 12 で新しいデータベースを作成する
ABBYY FlexiCapture 12 の管理および監視コンソールで新しいデータベースを作成し、新しいファイルストレージへのパスを指定します。詳細については、データベースを作成する を参照してください。
3
各Projectを開いて更新する
ABBYY FlexiCapture 12 の Project Setup Station で各Projectファイル (
*.fcproj) を開きます。Projectを開くと、ABBYY FlexiCapture 12 形式に更新されます。更新されたProjectは、以前のバージョンのプログラムと互換性がなくなります。
4
Document Definitions を公開する
更新されたProject内の Document Definitions は未公開になるため、使用する前に公開する必要があります。Project Setup Station で Project メニューの Document Definitions をクリックし、Document Definitions を選択してから Publish をクリックします。
5
各Projectを Application Server にアップロードする
File メニューの Upload Project to Server をクリックします。詳細については、プロジェクトをサーバーにアップロードする を参照してください。
