Skip to main content
Erstellen Sie für jeden Klassifikator einen Trainings-Batch, fügen Sie Trainingsbilder hinzu und weisen Sie Referenzklassen zu.

Einen Trainings-Batch erstellen

1

Ansicht für Trainings-Batches des Klassifikators öffnen

Führen Sie einen der folgenden Schritte aus:
  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Open Classifier Training Batches.
  • Wählen Sie im Menü View oder Klassifikationstraining die Option Open Classifier Training Batches.
  • Drücken Sie Ctrl+Alt+Shift+B.
2

Einen Batch erstellen

Klicken Sie mit der rechten Maustaste auf die Liste der Batches und wählen Sie im Kontextmenü New Batch aus.
3

Das Klassifikationsprofil festlegen

Wählen Sie im Menü Klassifikationstraining oder im Kontextmenü des Batches Change Classification Profile aus. Weitere Informationen finden Sie unter Klassifikationsprofile.
4

Das Gleichgewicht zwischen Precision und Recall festlegen

Wählen Sie im Menü Klassifikationstraining oder im Kontextmenü des Batches Change Recall/Precision Priority aus. Weitere Informationen finden Sie unter Gleichgewicht zwischen Precision und Recall.
5

Trainingsbilder hinzufügen

Führen Sie einen der folgenden Schritte aus:
  • Klicken Sie auf der Symbolleiste auf Load Images from Folders oder wählen Sie diese Option im Menü File aus. Wählen Sie anschließend den Ordner aus, der die Unterordner mit Bildern enthält. Jeder Unterordner sollte nur Bilder einer einzigen Klasse enthalten.
  • Klicken Sie im Kontextmenü des Batches oder im Menü File auf Load Images.
6

Eine Referenzklasse zuweisen

Verwenden Sie eine der folgenden Methoden:
  • Klicken Sie im Menü Klassifikationstraining auf Klasse festlegen oder klicken Sie mit der rechten Maustaste auf ein Dokument und dann auf Klasse festlegen. Wählen Sie eine Referenzklasse aus oder erstellen Sie eine und verknüpfen Sie sie mit einem Abschnitt oder einer Abschnittsvariante. Sie können Abschnitte oder Abschnittsvarianten als Referenzklassen verwenden. Die Referenzklasse muss denselben Namen wie die entsprechende Document Definition haben.
  • Wenn Sie die Bilder mit Load Images from Folders hinzugefügt haben, weisen Sie Klassen anhand des Unterordnernamens zu: Wählen Sie die Bilder aus und klicken Sie auf der Symbolleiste auf die Schaltfläche Set Class Based on Subfolder Name, oder wählen Sie Klassifikationstraining → Set Class Based on Subfolder Name aus.
Die Bildvorverarbeitung gilt nur für Seiten, die mit Load Images hinzugefügt wurden. Seiten, die mit Load Images from Folders hinzugefügt wurden, werden gemäß den Projekteigenschaften verarbeitet. Verwenden Sie für das Profil Image oder Combined Trainingsbilder mit demselben Farbschema (z. B. Schwarzweiß) wie die Bilder, die Sie klassifizieren möchten.
Wenn ein Klassenname mit dem Namen eines Abschnitts der Document Definition übereinstimmt, werden sie automatisch verknüpft, wenn Sie im Dialogfeld Class Mapping auf Autocorrect klicken. Weitere Informationen finden Sie unter Klassen Abschnitten der Document Definition zuordnen.

Referenzklassen anhand von Klassifikationsergebnissen zuweisen

Wenn Sie viele unsortierte Bilder für das Training haben, trainieren Sie den Klassifikator mit einigen davon und weisen Sie den übrigen anhand der Ergebnisse Referenzklassen zu.
1

Einige Referenzklassen manuell festlegen

Weisen Sie einigen Bildern mit Klasse festlegen Referenzklassen zu.
2

Klassifikator trainieren

Klicken Sie auf der Symbolleiste auf die Schaltfläche Train oder wählen Sie Train im Menü Klassifikationstraining oder im Kontextmenü aus.
3

Verbleibende Bilder klassifizieren

Wählen Sie die Bilder ohne Referenzklasse aus und klicken Sie auf der Symbolleiste auf die Schaltfläche Classify oder wählen Sie Classify im Menü Klassifikationstraining oder im Kontextmenü aus. Jedem Bild wird anhand des trainierten Klassifikators eine Ergebnisklasse zugewiesen.
4

Ergebnisklassen als Referenzklassen übernehmen

Klicken Sie bei ausgewählten Bildern im Menü Klassifikationstraining oder im Kontextmenü auf Set Class Based on Classification Result. Jedem Bild wird seine Ergebnisklasse als Referenzklasse zugewiesen. Korrigieren Sie alle Bilder, denen eine falsche Ergebnisklasse zugewiesen wurde.
Um vorhandene Erkennungsergebnisse beim Matching von Dokumentdefinitionen wiederzuverwenden, wählen Sie auf der Registerkarte Classification der Eigenschaften des Trainings-Batchs (Batch-Kontextmenü → Properties) die Option Prefer settings from batch type aus. Dadurch werden die Einstellungen für die Volltexterkennung synchronisiert, sodass Dokumente nicht erneut erkannt werden und die Klassifikation weniger Zeit beansprucht.