Skip to main content
Une fois les données reconnues, l’utilisateur les voit dans la fenêtre du document. Par défaut, les données sont disposées séquentiellement, avec des libellés correspondant aux noms des champs de la Document Definition. L’administrateur de la station peut modifier l’affichage des données, en les réorganisant ou en renommant certains éléments, en modifiant le formulaire de données dans le Document Definition editor.

Personnaliser l’affichage des données

1

Ouvrir le Document Definition editor

Ouvrez la Document Definition dans le Document Definition editor.
2

Afficher le formulaire de données

Cliquez sur View → Data Form ou appuyez sur Alt+F2.
3

Personnaliser le formulaire de données

Utilisez les commandes du menu contextuel pour personnaliser le formulaire de données.
Pour plus d’informations, voir Paramètres du formulaire de données. Pour restaurer les paramètres d’affichage par défaut du formulaire de données, cliquez sur Restore Default View dans le menu contextuel. Toutes les modifications effectuées par l’utilisateur sont perdues.

Propriétés des éléments du formulaire de données

Chaque type d’élément du formulaire de données possède son propre jeu de propriétés. Pour afficher les propriétés d’un élément, double-cliquez dessus, ou cliquez dessus avec le bouton droit, puis cliquez sur Properties dans son menu contextuel.

Onglet Position

  • Alignement – Ajuste l’alignement d’un élément sur les axes vertical et horizontal. Vous pouvez également utiliser les menus contextuels des éléments pour modifier leur alignement.
  • Marges – Modifie la distance, en points, entre un élément et les bords de sa cellule. Si vous spécifiez une marge nulle, FlexiCapture utilise la plus petite marge qui empêche le chevauchement des éléments. Vous pouvez également modifier les marges à l’aide des commandes du menu contextuel de l’élément, en faisant glisser l’élément dans sa cellule ou en déplaçant les bords droit ou inférieur de la cellule jusqu’à ce qu’ils touchent l’élément.
  • Définir la taille minimale – Spécifie la largeur et la hauteur minimales d’un élément. Si aucune taille minimale n’est spécifiée, la taille est déterminée automatiquement. Vous pouvez également modifier la largeur et la hauteur minimales en faisant glisser les bords de l’élément. Pour restaurer la taille par défaut de l’élément, cliquez dessus avec le bouton droit, puis cliquez sur Restaurer la taille par défaut dans le menu contextuel. Les éléments dont la taille minimale est calculée automatiquement sont mis en surbrillance en vert dans le formulaire de données ; ceux dont la taille minimale est spécifiée par l’utilisateur sont mis en surbrillance en rouge.
  • Largeur fixe – Indique que l’élément a une largeur fixe. Ce paramètre fonctionne uniquement si le champ est suffisamment grand pour contenir au moins un caractère. Si une très longue chaîne de texte est saisie dans un champ dont la largeur n’est pas fixe, le champ s’agrandit pour s’adapter au texte. Lorsque vous spécifiez une largeur fixe, les longues chaînes de texte sont renvoyées à la ligne pour s’adapter à la taille du champ.

Onglet Format (case d’étiquette)

  • Text – Le texte de l’étiquette (généralement le nom d’un champ ou une explication).
  • police – Modifie la police, la taille et le style de police. La police et la taille de police spécifiées dans la Document Definition sont utilisées par défaut. Pour modifier ces paramètres, désactivez l’option Use default.
Vous pouvez modifier l’étiquette d’un champ dans le formulaire de données sans changer le nom du champ dans la structure du document. Cela est utile lorsque vous ne pouvez pas modifier les noms de champs ou lorsque vous avez besoin de noms personnalisés pour les colonnes des tableaux. Vous pouvez également ajouter du texte, par exemple des explications pour les champs, en cliquant avec le bouton droit sur un espace vide dans le formulaire de données, puis sur Insert Text dans le menu contextuel.

Onglets Format et Instances (propriétés de groupe)

  • Paramètres d’affichage des groupes de champs – Modifiez l’apparence par défaut des groupes de champs dans la fenêtre du document. Cliquez avec le bouton droit sur un groupe dans le formulaire de données, ouvrez la boîte de dialogue de ses propriétés, sélectionnez l’onglet Format, puis choisissez l’une des options suivantes dans la liste déroulante Réduire le groupe :
  • Afficher la bordure – Affiche ou masque la bordure autour du groupe dans la fenêtre du document. Si un groupe contient des instances et que sa bordure est masquée, des éléments de contrôle rectangulaires apparaissent à gauche des instances. Utilisez ces contrôles pour supprimer une instance et ajouter une nouvelle instance juste au-dessus ou au-dessous de l’instance sélectionnée.
  • Afficher le prompt « Ajouter une nouvelle instance » – Affiche ou masque un lien invitant l’utilisateur à ajouter une instance pour les groupes ou les champs comportant des instances.
Les propriétés de l’élément décrites ici, la résolution de l’écran, le niveau de zoom du formulaire et le contenu des cellules sont utilisés pour calculer la position des champs dans le formulaire de données.

Paramètres du formulaire de données

Police et taille de police

Par défaut, le texte reconnu s’affiche en Arial 10 pt. Modifiez les paramètres par défaut dans la boîte de dialogue des propriétés de Document Definition (cliquez sur Document Definition → Document Definition Properties, puis sélectionnez l’onglet Data Form).
  • Données de champ – Paramètres de police du texte reconnu.
  • Étiquette de champ – Paramètres de police du texte explicatif et des étiquettes de champ.

Affichage des images des champs dans la fenêtre du document

Vous pouvez afficher une image des champs Text, Barcode, Coche et Groupe de coches sous les données reconnues dans la fenêtre du document.
Capture d'écran du formulaire de données de la fenêtre du document montrant un champ Addressing reconnu avec une image du champ affichée sous les données reconnues.
Pour afficher l’image d’un champ, cliquez avec le bouton droit sur le champ dans le formulaire de données et sélectionnez Ajouter une image du champ dans le menu contextuel. Une fois le traitement terminé, les données extraites s’affichent dans la fenêtre du document avec une image du champ en dessous.

Éléments Group

Plusieurs éléments peuvent être regroupés et placés sur le formulaire de données. Utilisez les commandes du menu contextuel pour aligner le groupe et définir les marges (supprimer ou rétablir les valeurs par défaut). Vous pouvez également supprimer ou verrouiller le groupe ; les éléments d’un groupe verrouillé ne peuvent pas être déplacés. Pour regrouper des éléments, sélectionnez-les en maintenant la touche Ctrl enfoncée tout en cliquant dessus, cliquez avec le bouton droit sur l’un d’eux, puis sélectionnez Group Selected dans le menu contextuel. Pour retirer des éléments d’un groupe, faites-les glisser hors du groupe.
Lorsqu’une étiquette ou une image est ajoutée à un champ, ces éléments sont regroupés.

Paramètres d’affichage des colonnes

Les colonnes du tableau non détectées lors de la reconnaissance peuvent être masquées. Vous pouvez masquer des colonnes à deux endroits :
  • Dans le formulaire de données – Ouvrez les propriétés du tableau et sélectionnez les colonnes à masquer dans la liste Sélectionner les colonnes à masquer lorsqu’elles sont vides de l’onglet Format.
  • Dans la fenêtre du document – Cliquez avec le bouton droit sur le titre du tableau et sélectionnez, dans le menu contextuel, les noms des colonnes à masquer.
Utilisez les boutons Monter et Descendre à droite de la liste pour modifier l’ordre des colonnes dans le document reconnu. Cette fonctionnalité n’est pas disponible dans les stations web.

Paramètres d’affichage des sections

Lorsque vous travaillez avec des jeux de documents ou des Document Definitions à plusieurs sections, vous pouvez souhaiter masquer certaines sections dans le formulaire de données. Ouvrez la boîte de dialogue des propriétés de la section à masquer et désactivez l’option Afficher lors de la vérification dans l’onglet Général.

Ordre de sélection des champs

L’ordre de vérification par défaut dans la fenêtre du document va de haut en bas et de gauche à droite. Vous pouvez modifier l’ordre de sélection des champs lorsque l’utilisateur appuie sur Tab, F4 ou F8. Pour modifier l’ordre, cliquez sur Ordre de tabulation dans le menu contextuel du formulaire de données. Dans la boîte de dialogue qui s’ouvre, sélectionnez l’option Personnalisé, puis utilisez les boutons situés à droite pour modifier l’ordre.
Cette fonctionnalité n’est pas disponible dans les stations web.

Zoomer sur l’image du document

Lors de la vérification, vous pouvez zoomer sur l’image du document à l’aide de la souris ou des commandes du menu contextuel. Un double-clic sur différentes zones de l’image du document modifie le niveau de zoom : Vous pouvez modifier l’ordre d’affichage horizontal ou vertical des pages en cliquant avec le bouton droit sur le titre de la fenêtre Document, puis en sélectionnant Organiser les pages verticalement dans le menu contextuel.
Vous pouvez également effectuer un zoom avant ou arrière en faisant défiler la molette de la souris tout en maintenant la touche Ctrl enfoncée.