Avant de commencer la saisie en masse de documents, testez vos Document Definitions. Les tests utilisent des documents ajoutés à des batches de test, qui utilisent la version locale de la Document Definition. Ouvrez les batches de test depuis View → Test Batches dans la fenêtre principale, ou depuis le Document Definition Editor en sélectionnant Batch → Switch to Test Batch.
Seul l’utilisateur qui a créé un batch de test peut travailler avec ce batch de test. Si nécessaire, un batch de travail peut être utilisé comme batch de test ; dans ce cas, il sert de source d’images pour le batch de test.
Vérifiez chaque Document Definition à l’aide d’au moins 20 images de documents. Si les documents sont remplis à la main, utilisez des documents remplis par des personnes différentes.
Test dans le Document Definition Editor
Vous pouvez tester une Document Definition directement dans le Document Definition Editor, sur l’image utilisée pour la créer. Pour démarrer le test, sélectionnez Testing → Run Test. Le formulaire de données s’affiche comme lors du traitement des documents et indique les erreurs de format, les caractères incertains et les erreurs de règle.
Utilisez le menu Testing → View pour réorganiser les fenêtres et le menu Testing → Verification pour parcourir les éléments de vérification, les caractères incertains et les erreurs de règle. Pour arrêter le test, cliquez sur Close ou sélectionnez Testing → Finish Test.
En mode test, la modification de la bordure d’un champ ne relance pas sa reconnaissance, contrairement à la modification des bordures de champ dans la fenêtre Document.
Test sur un batch de test
Pour tester votre Document Definition sur d’autres images, sélectionnez un batch de test dans le Document Definition Editor (Batch → Switch to Test Batch). Avant l’affichage de la boîte de dialogue de sélection du batch, ABBYY FlexiCapture vérifie si la Document Definition actuelle contient des erreurs. Si la Document Definition ne contient aucune erreur, elle est enregistrée et la boîte de dialogue de sélection du batch s’affiche. Lorsque vous sélectionnez un batch, la fenêtre principale devient active et bascule vers celui-ci.
Pour les batches de test, l’option Enable auto export est désactivée par défaut. Cela évite que les résultats de test soient enregistrés accidentellement dans les dossiers d’un projet de travail.
Copier ou déplacer des documents entre des batches
Vous pouvez copier ou déplacer des documents entre des batches, par exemple d’un batch de travail vers un batch de test à des fins de débogage. Toutes les informations sur le document, telles que la Document Definition associée et les données reconnues, sont conservées.
Pour copier ou déplacer des documents, sélectionnez-les dans la liste du contenu du batch. Appuyez sur Ctrl+C pour copier ou sur Ctrl+X pour déplacer (ou utilisez les boutons Copy et Cut de la barre d’outils, ou les commandes Copy et Cut du menu Edit). Ouvrez ensuite le batch cible et appuyez sur Ctrl+V (ou utilisez le bouton Paste de la barre d’outils, ou Edit → Paste).
Ce que le test permet de vérifier
Lors du test, effectuez l’ensemble des actions réalisées lors du traitement des documents. Le test permet ensuite de vérifier que :
Corriger les problèmes et publier
Si le test révèle des erreurs de règle, des valeurs de champ incorrectes ou d’autres problèmes, modifiez la Document Definition pour les corriger. Ce n’est qu’après avoir éliminé tous les problèmes détectés que vous pouvez publier la Document Definition et commencer la saisie en masse de documents.