Create an additional FlexiLayout
Any FlexiLayout created in ABBYY FlexiLayout Studio can be used as an additional FlexiLayout in FlexiCapture for Invoices. To extract a new type of field, create a new block with a unique name in a FlexiLayout and define the logic for finding it on images. When this FlexiLayout is added to a Document Definition, a new field with the same name as the new block in the FlexiLayout is created. If the name of the block in the additional FlexiLayout is the same as the name of a standard field in the Document Definition, the additional FlexiLayout is used to extract the block. ABBYY FlexiLayout Studio has several features for developing additional FlexiLayouts for invoices:- You can find the IDs of the vendor and the business unit of an invoice and reference a data set in a Document Definition.
- You can specify the positions of elements relative to fields that may be detected when the main FlexiLayout is applied.
- You can parametrize the FlexiLayout using an XML file, which lets you store and edit complex lists of keywords and other FlexiLayout parameters without editing the FlexiLayout or the Document Definition.
Add the FlexiLayout to a Document Definition
Open the Document Definitions dialog box
Edit the Document Definition
Open the Document Definition properties
Open the FlexiLayout tab
Load the FlexiLayout
.afl extension).Develop a FlexiLayout variant for a specific vendor
FlexiCapture for Invoices lets you use a separate FlexiLayout variant when processing invoices from a specific vendor. This additional FlexiLayout variant can be created automatically using training. If you are not satisfied with the variant, you can open it in ABBYY FlexiLayout Studio and manually change the field search algorithm.Enable training in the Document Definition
Open the Document Definition settings
Edit the additional fields and features
Enable training
Apply training to invoices from a vendor
You can train both existing fields and new ones.Add an invoice
Recognize it
Verify the vendor
Mark the field
Train
Review and edit the training batch
An Administrator can review and modify the Training batch created as a result of Operator-driven training.Open the training batch view
- For automatic training, add a few more sample invoices to the batch and specify the field regions. For better quality, use at least three sample invoices. For more information, see Training done by project administrators.
- To edit the FlexiLayout variant manually, export the trained FlexiLayout to ABBYY FlexiLayout Studio.
Export the trained FlexiLayout
- Click Training → Export Trained FlexiLayout… on the Project menu, or
- Right-click the batch and select Export Trained FlexiLayout… from the shortcut menu.
Open the project in FlexiLayout Studio
Remove the blocks you do not want to change
Specify the search algorithm
Export to an .afl file
.afl file by clicking Export… on the File menu.Import the FlexiLayout
- Click Training → Import FlexiLayout… on the Project menu, or
- Right-click the batch and click Import FlexiLayout… on the shortcut menu.
.afl file you created in the previous step.Recognize sample invoices
Check the results
Train a Document Definition for a specific vendor
To extract a new field from invoices from a specific vendor, create the field in the Document Definition, and then train the program to capture data from it.Create the field
Name the field
Train the program to capture the field
