Skip to main content

Voraussetzungen

  • ABBYY FlexiCapture Distributed ist auf dem lokalen Computer installiert, insbesondere die Project Setup Station
  • Ein Project ist in ABBYY FlexiCapture Version 12.0.1.530 oder neuer konfiguriert
  • Anmeldedaten eines Unternehmensadministrators für ABBYY FlexiCapture Cloud
  • Das Distributionspaket für den ABBYY FlexiCapture Connector for Appian

Project auf den Server hochladen

Wenn das Project bereits auf den Server hochgeladen wurde, klicken Sie stattdessen auf File → Open Project from Server und fahren Sie mit Webstationen konfigurieren fort.
1

Project öffnen

  1. Starten Sie die Project Setup Station und klicken Sie auf File → Open Project.
  2. Wählen Sie das ABBYY FlexiCapture-Project (Datei .fcproj) aus und klicken Sie auf Open.
2

Upload starten

Klicken Sie in der Symbolleiste auf Upload Project to Server.
3

Server und Anmeldedaten angeben

Gehen Sie im daraufhin geöffneten Dialogfeld wie folgt vor:
  1. Geben Sie den Namen des ABBYY FlexiCapture-Servers im Format https://europe.flexicapture.com#Company an, wobei Company der Mandantenname ist.
  2. Wählen Sie Use server authentication aus und geben Sie Ihre Anmeldedaten ein.
  3. Klicken Sie auf Test Connection, um sicherzustellen, dass die Anmeldedaten gültig sind.
  4. Klicken Sie auf OK und warten Sie, bis das Project hochgeladen ist.
Wenn die Version der Project Setup Station nicht mit der Version des Processing Server in der Cloud übereinstimmt, wird die Meldung Application Server version is not compatible. angezeigt.
4

Hochgeladenes Project öffnen

Öffnen Sie das Project vom Server. In der Titelleiste des Fensters der Project Setup Station wird die Adresse des Servers angezeigt, auf dem das geöffnete Project gehostet wird.

Webstationen konfigurieren

Mit diesem Verfahren können Sie die Einstellungen für Administration, Scannen und Verifizierung ändern.
1

Beim Mandanten anmelden

  1. Rufen Sie https://europe.flexicapture.com/ auf.
  2. Klicken Sie auf der Anmeldeseite auf Beim Mandanten anmelden und geben Sie den Unternehmensnamen sowie Ihre Anmeldedaten ein.
2

Eine Webstation öffnen

Öffnen Sie die benötigte Station im Block Verfügbare Webstationen.
Weitere Informationen zu den einzelnen Stationen finden Sie unter Administration and Monitoring Console, Web-Verifizierungsstation und Web-Scanning-Station.

Fügen Sie die Connector-Bibliotheken zur Dokumentdefinition hinzu

Führen Sie die verbleibende Konfiguration im auf den Server hochgeladenen Project durch.
1

Öffnen Sie die Dokumentdefinition

  1. Klicken Sie auf Project → Dokumentdefinitionen, um die Liste der Dokumentdefinitionen zu öffnen.
  2. Wählen Sie die gewünschte Dokumentdefinition aus und klicken Sie auf Edit. Das Fenster Dokumentdefinitionseditor wird geöffnet.
2

Öffnen Sie die Registerkarte .Net References

Klicken Sie auf Dokumentdefinition → Eigenschaften der Dokumentdefinition und wechseln Sie dann zur Registerkarte .Net References.
3

Fügen Sie die Bibliotheken hinzu

Klicken Sie auf Add und fügen Sie die folgenden Bibliotheken aus dem Distributionspaket für ABBYY FlexiCapture Connector for Appian als Attached file hinzu:
  • AfcDmsConnector.dll
  • AppianConnector.dll
  • DmsConnector.dll
  • Newtonsoft.Json.dll
4

Speichern Sie die Dokumentdefinition

Übernehmen Sie die Änderungen und speichern Sie die Dokumentdefinition.

Exportprofil für Appian erstellen

1

Assistenten für Exportprofile starten

  1. Klicken Sie auf Dokumentdefinition → Export settings.
  2. Klicken Sie auf Add. Der Assistent zum Erstellen eines neuen Exportprofils wird geöffnet.
2

Zieltyp auswählen

Wählen Sie in der Dropdown-Liste Type die Option Custom export (script) aus und legen Sie die Anwendungsbedingung für das Profil fest, beispielsweise Document condition: Errors are irrelevant. Klicken Sie auf Next.
3

Skripteditor öffnen

Klicken Sie auf Edit script.
4

Beispielskript einfügen

Wählen Sie im Fenster Skripteditor die Option Script language C# .Net aus und fügen Sie das Skript ExportScript - Appian - Configure by script.cs aus dem Ordner Samples des Distributionspakets ABBYY FlexiCapture Connector for Appian ein.
5

Exporteinstellungen im Skript festlegen

Legen Sie die Adresse des Appian-Servers, die ID des Knowledge Center, den Ordnernamen und den Record-Typ fest:
Repository enthält die ID des Knowledge Center in Appian. Geben Sie außerdem den Benutzernamen und das Kennwort des Appian-Benutzers sowie die Exporteinstellungen für Bilddateien an. Weitere Informationen finden Sie unter IExportImageSavingOptions.Um ein Feld aus der ABBYY FlexiCapture Dokumentdefinition einem Feld des Appian Record-Typs zuzuordnen, erstellen Sie ein Feldpaar:
Der Wert vor dem Komma ist der Feldname in der ABBYY FlexiCapture Dokumentdefinition. Der Wert nach dem Komma ist der Feldname in Appian.
6

Exportprofil benennen

  1. Speichern Sie die Änderungen, schließen Sie den Skripteditor, und klicken Sie auf Next.
  2. Geben Sie einen Namen für das neue Exportprofil ein, beispielsweise Export to Appian, und klicken Sie auf Finish.
7

Exportprofil aktivieren

Markieren Sie das neue Profil in der Liste der Exportprofile als aktiviert.
8

Dokumentdefinition veröffentlichen

Speichern Sie die Änderungen in der Dokumentdefinition, schließen Sie das Fenster Dokumentdefinitionseditor, und veröffentlichen Sie die neue Version der Dokumentdefinition.
Das Project in ABBYY FlexiCapture Cloud ist nun konfiguriert.