Skip to main content
Testen Sie Ihre Dokumentdefinitionen, bevor Sie mit der Masseneingabe von Dokumenten beginnen. Getestet wird mit Dokumenten, die Test-Batches hinzugefügt wurden und mit der lokalen Version der Dokumentdefinition arbeiten. Öffnen Sie Test-Batches im Hauptfenster über Ansicht → Test-Batches oder im Dokumentdefinitions-Editor, indem Sie Batch → Zu Test-Batch wechseln auswählen.
Nur der Benutzer, der einen Test-Batch erstellt hat, kann mit diesem Test-Batch arbeiten. Bei Bedarf kann ein Arbeits-Batch als Test-Batch verwendet werden; in diesem Fall dient er als Bildquelle für den Test-Batch.
Prüfen Sie jede Dokumentdefinition mit mindestens 20 Dokumentbildern. Wenn Dokumente von Hand ausgefüllt werden, verwenden Sie Dokumente, die von unterschiedlichen Personen ausgefüllt wurden.

Test im Dokumentdefinitions-Editor

Sie können eine Dokumentdefinition direkt im Dokumentdefinitions-Editor anhand des Bildes testen, mit dem sie erstellt wurde. Um den Test zu starten, wählen Sie Testing → Run Test. Das Datenformular wird wie bei der Dokumentverarbeitung angezeigt und weist auf Formatfehler, unsichere Zeichen und Regelfehler hin. Verwenden Sie das Menü Testing → View, um die Fenster neu anzuordnen, und das Menü Testing → Verification, um durch die Verifizierungselemente, unsicheren Zeichen und Regelfehler zu navigieren. Um den Test zu beenden, klicken Sie auf Close oder wählen Sie Testing → Finish Test.
Im Testmodus wird ein Feld durch Ändern seines Rands nicht erneut erkannt – anders als beim Ändern von Feldrändern im Document window.

Testen mit einem Test-Batch

Um Ihre Dokumentdefinition mit anderen Bildern zu testen, wählen Sie im Dokumentdefinitions-Editor einen Test-Batch aus (Batch → Zu Test-Batch wechseln). Bevor das Dialogfeld zur Batch-Auswahl angezeigt wird, prüft ABBYY FlexiCapture die aktuelle Dokumentdefinition auf Fehler. Wenn die Dokumentdefinition fehlerfrei ist, wird sie gespeichert und das Dialogfeld zur Batch-Auswahl wird angezeigt. Wenn Sie einen Batch auswählen, wird das Hauptfenster aktiv und wechselt zu diesem Batch.
Für Test-Batches ist die Option Auto-Export aktivieren standardmäßig deaktiviert. Dadurch wird verhindert, dass Testergebnisse versehentlich in den Ordnern eines Arbeitsprojekts gespeichert werden.

Dokumente zwischen Batches kopieren oder verschieben

Bei Bedarf können Dokumente zwischen Batches kopiert oder verschoben werden, z. B. zu Debugging-Zwecken von einem Arbeits-Batch in einen Test-Batch. Dabei bleiben alle Informationen zum Dokument erhalten, z. B. die zugeordnete Dokumentdefinition und erkannte Daten. Um Dokumente zu kopieren oder zu verschieben, wählen Sie sie in der Inhaltsliste des Batches aus. Drücken Sie Ctrl+C zum Kopieren oder Ctrl+X zum Verschieben (oder verwenden Sie die Schaltflächen Kopieren und Ausschneiden in der Symbolleiste bzw. die Befehle Kopieren und Ausschneiden im Menü Bearbeiten). Öffnen Sie anschließend den Ziel-Batch und drücken Sie Ctrl+V (oder verwenden Sie die Schaltfläche Einfügen in der Symbolleiste bzw. Bearbeiten → Einfügen).

Was durch Tests überprüft wird

Führen Sie beim Testen die gesamte Abfolge von Aktionen aus, die Sie auch bei der Verarbeitung von Dokumenten durchführen. Dabei wird überprüft, ob:

Probleme beheben und veröffentlichen

Wenn beim Testen Regelfehler, falsche Feldwerte oder andere Probleme erkannt werden, müssen Sie die Dokumentdefinition bearbeiten, um diese zu korrigieren. Erst wenn Sie alle erkannten Probleme behoben haben, können Sie die Dokumentdefinition veröffentlichen und mit der Masseneingabe von Dokumenten beginnen.