Skip to main content

Prerequisites

  • ABBYY FlexiCapture Distributed installed on the local computer, in particular the Project Setup Station
  • A project configured in ABBYY FlexiCapture version 12.0.1.530 or later
  • Company administrator credentials for ABBYY FlexiCapture Cloud
  • The ABBYY FlexiCapture Connector for Appian distribution package

Upload the project to the server

If the project is already uploaded to the server, click File → Open Project from Server instead and continue with Configure the web stations.
1

Open the project

  1. Start the Project Setup Station and click File → Open Project.
  2. Select the ABBYY FlexiCapture project (.fcproj file) and click Open.
2

Start the upload

Click Upload Project to Server on the toolbar.
3

Specify the server and credentials

In the dialog box that opens:
  1. Specify the name of the ABBYY FlexiCapture server in the format https://europe.flexicapture.com#Company, where Company is the tenant name.
  2. Select Use server authentication and specify your credentials.
  3. Click Test Connection to make sure the credentials are valid.
  4. Click OK and wait for the project to upload.
If the Project Setup Station version does not match the Processing Server version in the cloud, the message Application Server version is not compatible. appears.
4

Open the uploaded project

Open the project from the server. The title bar of the Project Setup Station window shows the address of the server hosting the open project.

Configure the web stations

Use this procedure to change the administration, scanning, and verification settings.
1

Log in to the tenant

  1. Go to https://europe.flexicapture.com/.
  2. On the login page, click Log in to Tenant and enter the company name and your login credentials.
2

Open a web station

Open the station you need from the Available web stations block.
For more information about what each station does, see Administration and Monitoring Console, Web Verification Station, and Web Scanning Station.

Add the connector libraries to the Document Definition

Perform the remaining configuration in the project uploaded to the server.
1

Open the Document Definition

  1. Click Project → Document Definitions to open the list of Document Definitions.
  2. Select the Document Definition you need and click Edit. The Document Definition Editor window opens.
2

Open the .Net References tab

Click Document Definition → Document Definition Properties, and then go to the .Net References tab.
3

Add each library

Click Add and add the following libraries from the ABBYY FlexiCapture Connector for Appian distribution package as Attached file:
  • AfcDmsConnector.dll
  • AppianConnector.dll
  • DmsConnector.dll
  • Newtonsoft.Json.dll
4

Save the Document Definition

Apply the changes and save the Document Definition.

Create the export profile for Appian

1

Start the export profile wizard

  1. Click Document Definition → Export settings.
  2. Click Add. A wizard for creating a new export profile opens.
2

Select the destination type

Select Custom export (script) from the Type drop-down list and set the profile application condition, for example Document condition: Errors are irrelevant. Click Next.
3

Open the script editor

Click Edit script.
4

Paste the sample script

In the Script editor window, select Script language C# .Net and paste the ExportScript - Appian - Configure by script.cs script from the Samples folder of the ABBYY FlexiCapture Connector for Appian distribution package.
5

Set the export settings in the script

Set the address of the Appian server, the knowledge center ID, the folder name, and the record type:
Repository holds the knowledge center ID in Appian. Also specify the user name and password of the Appian user, and the image file export settings. For more information, see IExportImageSavingOptions.To map a field from the ABBYY FlexiCapture Document Definition to a field from the Appian record type, create a field pair:
The value before the comma is the field name in the ABBYY FlexiCapture Document Definition. The value after the comma is the field name in Appian.
6

Name the export profile

  1. Save the changes, close the Script editor, and click Next.
  2. Enter a name for the new export profile, for example Export to Appian, and click Finish.
7

Enable the export profile

In the list of export profiles, mark the new profile as Enabled.
8

Publish the Document Definition

Save the changes in the Document Definition, close the Document Definition Editor window, and publish the new version of the Document Definition.
The project in ABBYY FlexiCapture Cloud is now configured.