Erstellen eines zusätzlichen FlexiLayouts
Jedes in ABBYY FlexiLayout Studio erstellte FlexiLayout kann in FlexiCapture for Invoices als zusätzliches FlexiLayout verwendet werden. Um einen neuen Feldtyp zu extrahieren, erstellen Sie in einem FlexiLayout einen neuen Block mit einem eindeutigen Namen und definieren die Logik, mit der er auf Bildern gefunden wird. Wenn dieses FlexiLayout zu einer Dokumentdefinition hinzugefügt wird, wird ein neues Feld mit demselben Namen wie der neue Block im FlexiLayout erstellt. Wenn der Name des Blocks im zusätzlichen FlexiLayout mit dem Namen eines Standardfelds in der Dokumentdefinition übereinstimmt, wird das zusätzliche FlexiLayout zum Extrahieren dieses Blocks verwendet. ABBYY FlexiLayout Studio bietet mehrere Funktionen für die Entwicklung zusätzlicher FlexiLayouts für Rechnungen:- Sie können die IDs des Vendors und des Geschäftsbereichs einer Rechnung ermitteln und in einer Dokumentdefinition auf einen Datensatz verweisen.
- Sie können die Positionen von Elementen relativ zu Feldern festlegen, die möglicherweise erkannt werden, wenn das Haupt-FlexiLayout angewendet wird.
- Sie können das FlexiLayout mithilfe einer XML-Datei parametrisieren. Dadurch können Sie komplexe Listen von Schlüsselwörtern und anderen FlexiLayout-Parametern speichern und bearbeiten, ohne das FlexiLayout oder die Dokumentdefinition zu bearbeiten.
Hinzufügen des FlexiLayouts zu einer Dokumentdefinition
Öffnen des Dialogfelds Dokumentdefinitionen
Bearbeiten der Dokumentdefinition
Öffnen der Eigenschaften der Dokumentdefinition
Öffnen der Registerkarte FlexiLayout
Laden des FlexiLayouts
.afl).Entwickeln Sie eine FlexiLayout-Variante für einen bestimmten Vendor
Mit FlexiCapture for Invoices können Sie bei der Verarbeitung von Rechnungen eines bestimmten Vendors eine separate FlexiLayout-Variante verwenden. Diese zusätzliche FlexiLayout-Variante kann mithilfe von Training automatisch erstellt werden. Wenn Sie mit der Variante nicht zufrieden sind, können Sie sie in ABBYY FlexiLayout Studio öffnen und den Feldsuchalgorithmus manuell ändern.Training in der Dokumentdefinition aktivieren
Die Einstellung der Dokumentdefinition öffnen
Zusätzliche Felder und Funktionen bearbeiten
Training aktivieren
Training für Rechnungen eines Vendors verwenden
Sie können sowohl vorhandene Felder als auch neue trainieren.Eine Rechnung hinzufügen
Rechnung erkennen
Vendor überprüfen
Feld markieren
Trainieren
Trainings-Batch überprüfen und bearbeiten
Ein Administrator kann den Trainings-Batch, der als Ergebnis eines vom Operator gesteuerten Trainings erstellt wurde, überprüfen und ändern.Die Trainings-Batch-Ansicht öffnen
- Fügen Sie für das automatische Training dem Batch einige weitere Beispielrechnungen hinzu und geben Sie die Feldregionen an. Verwenden Sie für bessere Ergebnisse mindestens drei Beispielrechnungen. Weitere Informationen finden Sie unter Von Projektadministratoren durchgeführtes Training.
- Wenn Sie die FlexiLayout-Variante manuell bearbeiten möchten, exportieren Sie das trainierte FlexiLayout nach ABBYY FlexiLayout Studio.
Das trainierte FlexiLayout exportieren
- Klicken Sie im Menü Project auf Training → Export Trained FlexiLayout…, oder
- klicken Sie mit der rechten Maustaste auf den Batch und wählen Sie im Kontextmenü Export Trained FlexiLayout….
Das Project in FlexiLayout Studio öffnen
Die Blöcke entfernen, die Sie nicht ändern möchten
Den Suchalgorithmus angeben
In eine .afl-Datei exportieren
.afl-Datei, indem Sie im Menü File auf Export… klicken.Das FlexiLayout importieren
- Klicken Sie im Menü Project auf Training → Import FlexiLayout…, oder
- klicken Sie mit der rechten Maustaste auf den Batch und klicken Sie im Kontextmenü auf Import FlexiLayout….
.afl-Datei an, die Sie im vorherigen Schritt erstellt haben.Beispielrechnungen erkennen
Die Ergebnisse prüfen
Eine Dokumentdefinition für einen bestimmten Vendor trainieren
Um ein neues Feld aus Rechnungen eines bestimmten Vendors zu extrahieren, erstellen Sie das Feld in der Dokumentdefinition und trainieren Sie anschließend das Programm darauf, Daten aus diesem Feld zu erfassen.Das Feld erstellen
Das Feld benennen
Das Programm auf die Erfassung des Feldes trainieren
