Skip to main content
Bei der Verarbeitung einer Rechnung sucht ABBYY FlexiCapture zunächst nach dem Vendor (dem Unternehmen, das die Rechnung ausgestellt hat) und dem Geschäftsbereich (dem Unternehmen oder der Abteilung, die die Rechnung erhalten hat). In den meisten Fällen bestimmt der Vendor die Sprache der Rechnung und das Format von Zahlen, Datumsangaben und Beträgen. Der Geschäftsbereich bestimmt die Steuersätze und die geltenden regulatorischen Anforderungen. ABBYY FlexiCapture verwendet all diese Informationen, um Rechnungsdaten zu erfassen und Validierungsregeln anzuwenden. Damit das Programm die Felder für Vendor und Geschäftsbereich finden kann, können Sie Vendor- und Geschäftsbereichsdatenbanken verwenden. Diese müssen mit den Datensätzen in Ihrer Dokumentdefinition verbunden werden. Ein Datensatz ist eine lokale Kopie einer Tabelle aus einer externen Datenbank, in der Informationen über Vendoren oder Geschäftsbereiche gespeichert werden. Die darin enthaltenen Werte können typisiert und normalisiert werden, und der Datensatz kann regelmäßig aktualisiert werden, damit er mit der externen Datenbank synchron bleibt. Weitere Informationen finden Sie unter Vorbereiten von Vendor- und Geschäftsbereichsdatenbanken. Vendor- und Geschäftsbereichsdatenbanken können auch für automatische und manuelle Datenprüfungen verwendet werden. Sie müssen keine Vendor- und Geschäftsbereichsdatenbanken verwenden. Ob Sie sie verwenden, wirkt sich auf die Unternehmenserkennung und das Feldtraining aus:

Vendor- oder Geschäftsbereich-Datenbank verbinden

Sie verbinden Vendor- und Geschäftsbereich-Datenbanken auf dieselbe Weise.
1

Das Dialogfeld „Dokumentdefinitionen“ öffnen

Öffnen Sie das Menü Project und klicken Sie auf Dokumentdefinitionen….
2

Die Dokumentdefinition bearbeiten

Klicken Sie im daraufhin geöffneten Dialogfeld auf die Schaltfläche Edit….
3

Die Eigenschaften der Dokumentdefinition öffnen

Öffnen Sie das Menü Dokumentdefinition und klicken Sie auf Eigenschaften der Dokumentdefinition….
4

Die Registerkarte „Data Sets“ öffnen

Öffnen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Data Sets.
5

Den Datensatz öffnen

Doppelklicken Sie auf die Zeile BusinessUnits (oder Vendors) oder klicken Sie auf die Schaltfläche Set Up…. Das Dialogfeld Data Set wird geöffnet.Ein Datensatz ist im Wesentlichen eine Datentabelle mit einer festen Anzahl von Spalten und Typen, die nicht geändert werden können. Sie ordnen jede Datensatzspalte einer Spalte aus einer externen Datenbank zu. Wenn eine Datenbank keine Tabelle mit den erforderlichen Daten enthält, erstellen Sie eine Ansicht mit diesen Daten und geben Sie diese Ansicht als Tabelle an.
6

Die Quelle auswählen

Wählen Sie Database aus der Dropdown-Liste Source aus. Wählen Sie den Quelltyp Script nur aus, wenn Sie den Datensatz per Skript aktualisieren möchten. Weitere Informationen finden Sie unter Datensätze aktualisieren.
7

Die Verbindungszeichenfolge angeben

Geben Sie die Verbindungszeichenfolge der Datenbank an. Sie können eine der vorhandenen Umgebungsvariablen aus dem Projekt auswählen oder durch Klicken auf die Schaltfläche Specify… eine neue Zeichenfolge definieren. Wenn Sie eine Umgebungsvariable aus dem Projekt verwenden, können Sie das Projekt verschieben und Verbindungen zu Datenbanken mit derselben Struktur herstellen, ohne die Dokumentdefinition zu bearbeiten.
8

Schema und Tabelle auswählen

Wählen Sie Data schema und Database table aus.
9

Die Spalten zuordnen

Ordnen Sie die Spalten aus dem Datensatz den entsprechenden Spalten in der externen Datenbank zu. Für jede Datensatzspalte können Sie die entsprechende Spalte der externen Datenbank oder einen Wert angeben.Die Liste Match fields enthält:
  • die Namen der Spalten im Datensatz.
  • die entsprechenden Spalten aus der externen Datenbank.
  • die Spalte Found, in der ein Häkchen angezeigt wird, wenn eine Zuordnung zwischen dem Datensatzfeld und einer Datenbankspalte hergestellt wurde.
  • die Spalte Normalization, die den für den Wert verwendeten Normalisierungstyp anzeigt.
Standardmäßig steht in jedem Feld der Spalte External Database des Datensatzes der Wert selbst. Das bedeutet, dass keine externe Datenbankspalte angegeben wurde. Durch die Normalisierung können mehrere leicht unterschiedliche Werte als identisch behandelt werden. Weitere Informationen finden Sie unter Normalisierung von Werten in Datensätzen.Um jede Spalte zuzuordnen, wählen Sie sie in der Tabelle aus und klicken Sie auf die Schaltfläche Edit…. Weitere Informationen finden Sie unter Eine Datensatzspalte einer Datenbankspalte zuordnen.
10

Benutzerdefinierte Spalten hinzufügen (optional)

Verwenden Sie die Schaltfläche Add…, um einem Datensatz benutzerdefinierte Spalten hinzuzufügen und entsprechende Spalten in einer externen Datenbank anzugeben. Verwenden Sie die Schaltflächen Edit… und Delete, um komplexe Spalten zu verwalten. Vordefinierte Spalten (gekennzeichnet durch das Sperrsymbol) können nicht gelöscht werden.
11

Einen Aktualisierungszeitraum festlegen

Geben Sie im Datensatz einen Aktualisierungszeitraum für die Datenbank an, wenn automatische Aktualisierungen erforderlich sind.
12

Skriptvalidierung aktivieren (optional)

Um Datensätze mithilfe eines Skripts zu validieren, aktivieren Sie die Option Check records using scripts. Weitere Informationen finden Sie unter Datensatz-Validierungsskripte.
13

Änderungen speichern

Speichern Sie Ihre Änderungen.

Eine Datensatzspalte einer Datenbankspalte zuordnen

1

Die Spaltenzuordnung öffnen

Wählen Sie in der Liste Match fields die Spalte aus und klicken Sie auf die Schaltfläche Edit…. Das Dialogfeld Datensatz-Spaltenzuordnung wird geöffnet.
2

Die Datenbankspalte auswählen

Wählen Sie die passende Datenbankspalte aus der Liste Datenbankspalten aus.Wenn Ihre Datenbank keine passende Spalte für eine Datensatzspalte enthält, lesen Sie die Abschnitte Vendors-Datensatz und BusinessUnits-Datensatz.
3

Mehrere Werte einrichten (optional)

Rechnungen desselben Vendors können unterschiedliche Firmennamen und Adressen enthalten. Wenn mehrere Werte zu demselben Vendor (mit derselben VATID) gehören, speichern Sie diese in verschiedenen Spalten der externen Datenbanktabelle oder -ansicht, beispielsweise Name1, Name2, Address1, …, AddressN. Anschließend können Sie Mehrere Spalten… aus der Liste auswählen und der Datensatzspalte beliebig viele Datenbankspalten zuordnen.Die externe Datenbank enthält möglicherweise nur einen Wert für den Firmennamen oder die Straße, während auf Rechnungen mehrere gängige Schreibweisen dieser Angaben vorkommen können. Für eine optimale Erkennungsqualität sollte der Text in diesen Feldern auf einer Rechnung möglichst genau mit dem entsprechenden Text im Datensatz übereinstimmen. Weitere Informationen finden Sie unter Spalten mit mehreren Werten in einem Datensatz.Um mehrere Spalten zu erstellen, geben Sie im Feld Maximale Variantenanzahl die Anzahl der zulässigen Spalten für ein Feld an. Bediener können diesen Spalten später Werte hinzufügen. Wenn Sie eine Zahl angeben, die kleiner als die tatsächliche Anzahl der Spalten ist, wird sie bei der Aktualisierung des Datensatzes automatisch erhöht. Wenn Sie eine Zahl angeben, die größer als die tatsächliche Anzahl der Spalten ist, werden leere Spalten hinzugefügt.
4

Den Normalisierungstyp auswählen

Wählen Sie aus der Liste Normalization den Eintrag aus, der am besten zum Datentyp der Spalte passt. Weitere Informationen finden Sie unter Normalisierung von Werten in Datensätzen. Aktivieren Sie bei Bedarf die Option Store normalized value.
5

Die Option „Darf nicht leer sein“ festlegen

Aktivieren Sie bei Bedarf die Option Darf nicht leer sein. Diese Option legt fest, dass eine Spalte Werte enthalten muss. Wenn die Spalte keine Werte enthält, wird der Datensatz als ungültig markiert.Darf nicht leer sein ist für die Spalte BusinessUnitId standardmäßig aktiviert, wenn die folgenden beiden Bedingungen erfüllt sind: Ihre Dokumentdefinition enthält einen Vendors-Datensatz, der eine externe Datenbank als Quelle verwendet, und der Wert des Feldes Vendor hängt vom Wert des Feldes Geschäftsbereich ab. Wenn der Vendors-Datensatz eine andere Quelle verwendet, aktivieren Sie diese Option manuell.
6

Die Zuordnung speichern

Speichern Sie die Änderungen im Dialogfeld Datensatz-Spaltenzuordnung.

Die Registerkarte Data Sets

Auf der Registerkarte Data Sets sind alle Datensätze mit den folgenden Spalten aufgeführt: Sie können die Datensätze über die Schaltflächen rechts neben der Liste verwalten: Die Datensätze Vendors und BusinessUnits werden im Projekt gespeichert und müssen mit einer externen Datenbank synchronisiert werden, deren Daten sich im Laufe der Zeit ändern können. Die Synchronisierung erfolgt beim Öffnen des Projekts, jedoch nur, wenn die seit der vorherigen Synchronisierung verstrichene Zeit den angegebenen Aktualisierungszeitraum überschreitet. Weitere Informationen finden Sie unter Datensätze aktualisieren.

Datensätze eines Datensatzes anzeigen und bearbeiten

Um die Datensätze eines Datensatzes anzuzeigen oder zu bearbeiten, wählen Sie ihn auf der Registerkarte Data Sets im Dialogfeld „Eigenschaften der Dokumentdefinition“ aus und klicken Sie auf die Schaltfläche View…. Alle Datensätze gehören zu einer von drei Datensatzgruppen. Sie können die Datensatzgruppe, die Sie anzeigen möchten, in der Dropdown-Liste Record group auswählen. Klicken Sie auf die Schaltfläche Set…, um Datensätze nach ihren Werten in einer der Spalten der Liste zu sortieren und zu filtern. Die Schaltfläche Reset deaktiviert den Filter. Damit die Sortierung und Filterung auch auf neu hinzugefügte oder bearbeitete Datensätze angewendet wird, richten Sie den Filter erneut ein. Für jede Datensatzgruppe stehen unterschiedliche Aktionen zur Verfügung:
  • Das Hinzufügen und Bearbeiten von Datensätzen ist nur möglich, wenn die Option Primary key aktiviert ist. Datensätze in den Standard-Datensätzen PurchaseOrders und PurchaseOrderItems können nicht hinzugefügt oder bearbeitet werden.
Beim Hinzufügen oder Bearbeiten von Datensätzen darf die Anzahl der Werte, die Sie für ein Feld angeben können, den für dieses Feld im Dialogfeld Datensatz-Spaltenzuordnung festgelegten Wert Maximale Variantenanzahl nicht überschreiten. Sie können die Schaltflächen Schaltfläche Hinzufügen und Schaltfläche Entfernen in den Dialogfeldern Add Record und Edit Record verwenden, um Datensätze zu verwalten.

Datenbankprüfungsregeln

Die Invoice Document Definition enthält Regeln, mit denen Daten in den Feldgruppen Vendor und Geschäftsbereich mit der Datenbank abgeglichen werden. Dabei handelt es sich um Standardregeln vom Typ Database Check mit den Namen (Rejected) Vendor should be found in the database und (Rejected) Business Unit should be found in the database. Wie Sie Regeln in der Liste finden, erfahren Sie unter Rules. Sie können die Eigenschaften dieser Regeln anzeigen, um herauszufinden, wie jedes Feld in den Gruppen Vendor und Geschäftsbereich geprüft wird:
  • Welche Felder exakt mit Datensätzen im Datensatz (und damit in der Datenbank) übereinstimmen müssen.
  • Welche Felder nicht exakt übereinstimmen müssen.
  • Welche Felder einfach aus der Datenbank übernommen werden.
Sie können auch ein Feld angeben, das als Primärschlüssel zum Auswählen eines Datensatzes aus dem Datensatz verwendet wird. Weitere Informationen finden Sie unter Datenbankprüfungsregel. Datenbankprüfungsregeln werden automatisch angewendet, wenn die Rechnung erkannt wird, und danach jedes Mal, wenn ein Operator während der Verifizierung Felder in der Gruppe ändert.

Datensätze bei der Rechnungsverarbeitung nachschlagen

Wenn ein Vendor oder ein Geschäftsbereich nicht automatisch ermittelt wurde, kann der Operator den entsprechenden Datensatz aus der Datenbank (d. h. dem Datensatz) auswählen. Siehe Looking up vendors and business units in the database.

Vendor- und Geschäftsbereich-Datensätze ändern und hinzufügen

Sie können Operators erlauben, während der Verifizierung neue Vendor- und Geschäftsbereich-Datensätze zu Datensätzen hinzuzufügen (wenn sie nicht in der Datenbank gefunden werden) und vorhandene Einträge zu bearbeiten. Diese Daten werden nicht in externen Vendor- und Geschäftsbereich-Datenbanken gespeichert, aber sie werden bei der Rechnungsverarbeitung und bei Regelprüfungen verwendet. Weitere Informationen finden Sie unter Enabling additional program features for operators. Weitere Informationen zu Datenbank-Lookups finden Sie unter Looking up vendors and business units in the database.